Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Archivo Ayuda configurando htaccess
#1
Buenas!

Siento abrir un post más sobre lo mismo pero no encuentro mi caso concreto.
Al acceder a mi web no da error 500 pero sí todas estas líneas al principio que antes no salían: http://www.clanlacosanostra.com.ar/

[phpBB Debug] PHP Warning: in file /includes/functions_content.php on line 1273: base64_decode() has been disabled for security reasons
(...)

En mi caso, el .htaccess de esa web lo tengo así:
Código:
#
# Uncomment the statement below if you want to make use of
# HTTP authentication and it does not already work.
# This could be required if you are for example using PHP via Apache CGI.
#
#<IfModule mod_rewrite.c>
#RewriteEngine on
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#</IfModule>

<Files "config.php">
Order Allow,Deny
Deny from All
</Files>

<Files "common.php">
Order Allow,Deny
Deny from All
</Files>

RewriteEngine On
RewriteCond %{HTTP_HOST} ^clanlacosanostra.com.ar$ [NC]
RewriteRule ^(.*)$ http://www.clanlacosanostra.com.ar/$1 [R=301,L]

Bueno he probado añadiendo las líneas que comentáis al final del archivo, pero no pasa nada o al revés, al añadirlas me da el error 500.

Muchas gracias!
#2
hace esto http://foro.skylium.com/tema-Error-500-e...9#pid98339

y después con lo otro , el host al parecer no permite base64 , la verdad ahí no se

espera a desarrollo Lengua
#3
(22-08-2012, 12:52 AM)goro99 escribió: hace esto http://foro.skylium.com/tema-Error-500-e...9#pid98339

y después con lo otro , el host al parecer no permite base64 , la verdad ahí no se

espera a desarrollo Lengua

Gracias Goro, ya lo he hecho como he comentado, pero o no he sabido ponerlo en su sitio correcto, o no hace efecto tal como está el resto del htaccess.

Un saludo!
#4
Marco en seguimiento

Código:
#
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
</IfModule>

<Files "config.php">
Order Allow,Deny
Deny from All
</Files>

<Files "common.php">
Order Allow,Deny
Deny from All
</Files>

RewriteEngine On
RewriteCond %{HTTP_HOST} ^clanlacosanostra.com.ar$ [NC]
RewriteRule ^(.*)$ http://www.clanlacosanostra.com.ar/$1 [R=301,L]

Prueba con ese
WWW
#5
Lo tuyo es diferente, espera a Minenage que es podrá darte una solución.
WWW
#6
Eso no tiene nada que ver con el htaccess como lo dice el mensaje de error , el error esta en /includes/functions_content.php Linea: 1273

La razón es que el host no permite base64

como arreglarlo: ahí si que no sé Triste
#7
Me sale este mensaje (ACLARO QUE NO TENGO .htaccess)
Tampoco me aparecen las imágenes de los artículos
La web es http://www.ftatvsatelital.com.ar/fta

Warning: base64_decode() has been disabled for security reasons in /home/ptavella/public_html/fta/index.php on line 1

Warning: base64_decode() has been disabled for security reasons in /home/ptavella/public_html/fta/index.php on line 1

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/ptavella/public_html/fta/index.php:1) in /home/ptavella/public_html/fta/index.php on line 9

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/ptavella/public_html/fta/index.php:1) in /home/ptavella/public_html/fta/index.php on line 9

Warning: base64_decode() has been disabled for security reasons in /home/ptavella/public_html/fta/global_header.php on line 1

Warning: base64_decode() has been disabled for security reasons in /home/ptavella/public_html/fta/global_header.php on line 1

Warning: base64_decode() has been disabled for security reasons in /home/ptavella/public_html/fta/global_mainpage.php on line 1

Warning: base64_decode() has been disabled for security reasons in /home/ptavella/public_html/fta/global_mainpage.php on line 1

Warning: base64_decode() has been disabled for security reasons in /home/ptavella/public_html/fta/global_footer.php on line 1

Warning: base64_decode() has been disabled for security reasons in /home/ptavella/public_html/fta/global_footer.php on line 1
#8
bseca escribió:Bueno he probado añadiendo las líneas que comentáis al final del archivo, pero no pasa nada o al revés, al añadirlas me da el error 500.

Muchas gracias!
en tu caso deberás esperar a Miennage para que te dé una respuesta, disculpa el problema.

ptavella escribió:Me sale este mensaje (ACLARO QUE NO TENGO .htaccess)
Tampoco me aparecen las imágenes de los artículos
La web es http://www.ftatvsatelital.com.ar/fta

Warning: base64_decode() has been disabled for security reasons in /home/ptavella/public_html/fta/index.php on line 1

Warning: base64_decode() has been disabled for security reasons in /home/ptavella/public_html/fta/index.php on line 1

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/ptavella/public_html/fta/index.php:1) in /home/ptavella/public_html/fta/index.php on line 9

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/ptavella/public_html/fta/index.php:1) in /home/ptavella/public_html/fta/index.php on line 9

Warning: base64_decode() has been disabled for security reasons in /home/ptavella/public_html/fta/global_header.php on line 1

Warning: base64_decode() has been disabled for security reasons in /home/ptavella/public_html/fta/global_header.php on line 1

Warning: base64_decode() has been disabled for security reasons in /home/ptavella/public_html/fta/global_mainpage.php on line 1

Warning: base64_decode() has been disabled for security reasons in /home/ptavella/public_html/fta/global_mainpage.php on line 1

Warning: base64_decode() has been disabled for security reasons in /home/ptavella/public_html/fta/global_footer.php on line 1

Warning: base64_decode() has been disabled for security reasons in /home/ptavella/public_html/fta/global_footer.php on line 1
En cada uno de tus archivos php se encuentra una cadena en la primera linea que utiliza decode_64

he modificado el index, global_header, global_mainpage, global_footer pero veo que siguen saliendo errores, por lo que te sugiero investigues sobre tu problema ya que involucra un fallo de seguirdad apra tu web.

igualmente turnaré tu caso a mine para saber si podemos hacer algo para solucionar el problema por parte nuestra

Una vez más disculpen la molestia, todo es para mejorar la seguridad de sus datos en el servidor.
[Imagen: bann.png]
WWW
#9
Ahora ya deberían poder acceder a sus webs sin problemas. base64_decode ha sido habilitado de nuevo. Se trataba de una medida provisional para contener temporalmente una vulnerabilidad descubierta.

Saludos.
[Imagen: firmabp.jpg][Imagen: mineenlineaentregadispo.jpg]
WWW
#10
Gracias, ya está funcionando bien.


Posibles temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Solucionado: problema .htaccess DipDip 1 217 23-02-2015, 03:51 PM
Último mensaje: papi
  Solucionado: htaccess peta despues de la update TheBomberbe 13 519 18-12-2014, 03:38 PM
Último mensaje: TheBomberbe
Gran sonrisa Solucionado: Configurando un certificado SSL ariel 27 1,489 17-08-2013, 02:49 PM
Último mensaje: Juliens
  Solucionado: Problema htaccess SoyUnNick 18 1,125 05-05-2013, 03:17 PM
Último mensaje: Dark_Soul
  Archivo: Redirección con .htaccess DarkFinder 5 688 12-02-2013, 07:23 PM
Último mensaje: Juliens
  Archivo: problema con .htaccess Hostingbir 10 1,295 11-01-2013, 02:25 AM
Último mensaje: Hostingbir
  Archivo: ayuda con .htaccess TOMMYNRH 11 1,161 17-12-2012, 05:25 AM
Último mensaje: JUNIOR26
  Archivo: Ayuda con mi .htaccess Razor007 5 600 04-09-2012, 12:44 AM
Último mensaje: JUNIOR26
  Archivo: .Htaccess wordpress koenz 3 632 22-08-2012, 10:11 PM
Último mensaje: Minenage



Usuarios navegando en este tema: 1 invitado(s)