Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Error en las alertas.
#1
Si vas a configuración de alertas, te manda un error de archivo de idioma:


El botón manda a esta URL.

http://foro.skylium.com/usercp.php?actio...t_settings

Y el error mostrado es este:

/home/skylium/public_html/skylium.com/foro/inc/languages/espanol/.lang.php does not exist


Debe haber una referencia mal indicada en el plugin, porque no dice que archivo no existe, pero es uno sin nombre, solo toma la extensión, igualmente me sucede si cambio el idioma por el Inglés. Aunque no sale la url, pues he visto como mandarlo y simplemente lo puse yo mismo xD.

/home/skylium/public_html/skylium.com/foro/inc/languages/english/.lang.php does not exist

Pero sale igualmente error en ese enlace, para que lo revisen de ser necesario, saludos...

Igualmente al tema le hacen falta declarar bien variables del idioma, porque tiene muchas que no toma porque no esta bien estructurado xD.
No hay nada mas infinito que el unverso y la estupidez humana, aunque del universo no estoy tan seguro...
WWW
#2
Pues si que es un error en el plugin.
Esperemos a los de desarrollo para que vean como solucionan el error, tal vez solo sea un punto que está de mas en la referencia al archivo .php del idioma.
WWW
#3
Hoy me pasé, literal, toda la tarde revisando los archivos de idioma en busca del problema. Pasa que no entiendo porque el error si hace no mucho no salía ese error y no se han realizado cambios que puedan comprometer las alertas.

Voy a volver a revisar mañana o pasar el pack en moderación para que me ayuden a revisar. Lo que encontré fue un archivo de lenguaje de las alertas en español que estaba sin cerrar el tag de php, pero solucioné eso y sigue saliendo el mismo error
WWW
#4
Disculpen mi ignorancia pero no hay un punto de mas?
despues de .../espanol/ hay un punto ->.-<lang.php
no sera solo /home/skylium/public_html/skylium.com/foro/inc/languages/espanol/lang.php ???
WWW
#5
Lo que sucede es que debe haber una variable omitida que llama al idioma, porque por defecto los plugins son desarrollados con esa estructura, por ejemplo si creas un archivo para un plugin, debes colocar ciertas características y de ahi llamar a los lenguajes como tu desees y anexarlos al archivo respetando una estructura ya predefinida por el mismo script.

Por ejemplo:

este archivo yo lo llamaría al del plugin myalerts.php y asi mismo llamaría a todas mis variables de funciones internas para que sea respetado, pero esto es porque asi funciona el script mismo, como ya dije previamente, entonces al idioma podrías llamarle myalerts.lang.php. Debe haber un archivo de idioma en la carpeta english por defecto y de ahi las traducciones, en este caso debe ser espanol xD. Pero el archivo debe llamarse igual en ambos casos, lo que sucede es que al ir al enlace que marco, ya sea el idioma inglés o español manda el mismo error, debe estar dentro del mismo plugin este llamado, en la parte del hook (enganche) que hace referencia al Panel de Control de Usuario, ya que es en esa parte, cuando estas en opciones de tu panel de control cuando sucede esto, a veces me pongo a navegar para ver las opciones que desconozco y aprender un poco más y fué que asi me encontré con dicho error y no sabía donde reportarlo, no es algo que yo haya visto previamente, porque no he utilizado ese plugin, si no habría dicho que sucede o que pudiera pasar, pero se me hizo una curiosidad que quise compartir con ustedes Gran sonrisa.

Gracias de antemano y un saludo, por aqui andaremos viendo que cosa.
No hay nada mas infinito que el unverso y la estupidez humana, aunque del universo no estoy tan seguro...
WWW
#6
ok, a ver si Juliens le da la solucion a eso
WWW
#7
Esto me sucedió una vez porque la etiqueta de php estaba sin cerrar, pero ahora si no se que puede ser xD

Pero me diste una idea DArk, lo revisaré en lo que me saque un poco de tiempo
WWW
#8
Yo inclusive he pensado utilizar este mismo plugin en mi sitio para analizarlo xD, asi mismo como muchos otros que he utilizado, mas que nada porque veo que muchos tienen problemas, o porque tienen mucha audiencia xD, este es de mucha audiencia, Google SEO por ejemplo era de problemas, pero no lo utilizo yo xD. Este si me dan ganas, porque todos ya estan utilizándolo y simplemente es un muy buen complemento de MyBB.

Al igual mirandolo de cerca puedo saber que cosa, asi que igualmente voy a probarlo para ver que cosa sucede y asi ver si puedo ver donde reside el problema y saber como poder darle una solución xD.

AGREGO ESTO:

Al parecer el error es simplemente porque todos los archivos del plugin no estan cerrados, les hace falta al final de cada archivo php el cerrar la etiqueta.

?>

Esto le falta a todos los archivos, yo asi los puse y funciona al menos ese enlace, lo de las alertas, aún no lo he probado como se configura o esas cosas, lo iré probando poco a poco, porque creo que debo irme con calma xD.
No hay nada mas infinito que el unverso y la estupidez humana, aunque del universo no estoy tan seguro...
WWW
#9
Yo voy a revisar, de nuevo D:, los archivos del plugin porque ya revisé los de idiomas y agregué lo que comentas y sigue sucediendo el mismo error, espero solucionarlo.

PD: Felicidades @Dark Neo por tu nuevo rango ^^
WWW
#10
Gracias, xD, yo baje la versión de github, porque parece que estan actualizando a una nueva en el sitio porque sale el mensaje típico de cuando será una actualización que ya esta en camino para ser revisada xD.

Sin embargo los archivos los miré y en todos les falta el cierre de las etiquetas de php, las cuales cuando las dejas abiertas y son mas de un llamado, hacen que sucedan algunos errores de este tipo, ya que no encuentran un final de la instrucción, yo miré el archivo, luego lo traduje y acomode lo que hacía falta, en este caso el cierre de los archivos php. Lo probé y me funciona lo del enlace este, pero no he probado aún como funciona la mod, jajaja. Ya que no he tenido mucho tiempo, pero ya ire viendo conforme pase el tiempo, porque mi foro es de poca actividad y a veces pasan semanas sin mensajes o cosas nuevas, asi que, mmmm, me será algo dificil testearlo, pero al menos esa parte va bien de momento xD.
No hay nada mas infinito que el unverso y la estupidez humana, aunque del universo no estoy tan seguro...
WWW


Posibles temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Revision de mensajes de alertas. Dark Neo 7 712 10-08-2013, 05:49 AM
Último mensaje: jebcalix



Usuarios navegando en este tema: 1 invitado(s)