Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema al instalar VHCS
#1
Hola compañeros,

Necesito su ayuda con este panel de control.

El problema es que al instalarlo me va pidiendo datos de base de datos, de usuario, ftp, etc...
Hasta ahí todo bien. Ahora en la parte que me pide el email, luego de que lo ingreso me da este error..

Cita:Use of uninitialized value $fgid in getgrnam at ./vhcs2-setup line 799, <STDIN> line 8.
Use of uninitialized value $cfg{"CMD_GROUPADD"} in concatenation (.) or string at ./vhcs2-setup line 803, <STDIN> line 8.
Use of uninitialized value $fgid in concatenation (.) or string at ./vhcs2-setup line 803, <STDIN> line 8.
ERROR: External command ' ' returned '255' status !

No se que puede ser, un colega me dijo que faltan variables de configuración.
Cita:Analizando el código y las advertencias, parece que te faltan variables de configuración, al menos MTA_MAILBOX_UID_NAME y MTA_MAILBOX_GID_NAME
El problema, es que no tengo ni idea donde van declaradas esas variables. Ya leí el código pero no tengo mucha idea sobre programación en linux.

Las líneas donde da el error son estas.
Cita:783.- sub setup_system_users {
784.-
785.- my ($rs, $rdata) = (undef, undef);
786.-
787.- push_el(\@main::el, 'setup_system_users()', 'Starting...');
788.-
789.- my ($fuid, $fgid) = ($main::cfg{'MTA_MAILBOX_UID_NAME'}, $main::cfg{'MTA_MAILBOX_GID_NAME'});
790.-
791.- my ($uid, $gid) = (undef, undef);
792.-
793.-
794.- my @udata = ();
795.-
796.- my @gdata = ();
797.-
798.-
799.- @gdata = getgrnam($fgid);
800.-
801.- if (scalar(@gdata) == 0) { # we have not this one group data;
802.-
803.- my $cmd = "$main::cfg{'CMD_GROUPADD'} $fgid";
804.-
805.- $rs = sys_command($cmd);
806.-
807.- return $rs if ($rs != 0);
808.-
809.- @gdata = getgrnam($fgid);
810.-
811.- }
812.-
813.- $gid = $gdata[2];
814.-
815.-
816.- @udata = getpwnam($fuid);

A ver si alguien puede darme una mano con esto que me esta volviendo loco!! :/

Un saludo a todos y espero puedan ayudarme..
Se buscan colaboradores para comenzar con un foro de programación en general.

www.programarg.com
WWW


Posibles temas similares...
Tema Autor Respuestas Vistas Último mensaje
Bug Problema conectando con MySql remoto yuma2009 2 190 01-02-2018, 11:52 AM
Último mensaje: easy english
  Solucionado: problema con insert into sql efbsfcd 5 213 26-01-2018, 11:40 AM
Último mensaje: Vicen
  Problema conexion remota mysql efbsfcd 2 284 07-07-2017, 07:19 AM
Último mensaje: efbsfcd
Bombilla [Tutorial] SSL Gratis, Conseguir e Instalar Certificado DarkMaster 16 1,197 06-01-2016, 01:32 AM
Último mensaje: DarkMaster
  Cómo instalar Bootstrap habacuc78 3 403 22-12-2015, 10:33 PM
Último mensaje: Taquion
  Enlaces oficiales para instalar blogs en nuestra web aerotuning 4 547 01-05-2015, 07:03 PM
Último mensaje: mispracticas2009
  Problema con la web dormio 5 410 17-12-2014, 03:26 PM
Último mensaje: jebcalix
  Problema con transición css celticslment 3 430 15-11-2014, 11:16 AM
Último mensaje: kakashi-sensei
  Problema con imagenes othgeg 14 1,052 01-09-2014, 12:43 AM
Último mensaje: romeho
  THT - Problema con licencia Gonzalo 1 455 08-12-2013, 04:59 AM
Último mensaje: DarkMaster



Usuarios navegando en este tema: 1 invitado(s)