Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema con los spoilers
#1
Bug 
Hola, hoy necesito la ayuda de todos los que sepan de MyBB (en especial @Dark_Soul).
Verán, hace poco noté que el spoiler que había instalado dejó de funcionar (el botoncito no hacía nada en ningún navegador). Lo primero que hice fue reinstalar el plugin, y nada, seguía igual. Paso siguiente probé otros plugins, códigos BB personalizados... de todo, y seguía sin funcionar; no logré hacer que el botón de 'Mostrar' funcionara...
Eso tiene que haber sucedido debido a algún cambio que hice... no se que pasa, pero necesito que el spoiler funcione, es una herramienta muy necesaria en mi foro Indeciso
Metas¡Completadas!
  • Ascender a moderador [✔ Completada]
  • Ganar 50 puntos de reputación (ver) [✔ Completada]
  • Ganar 100 puntos de reputación (ver) [✔ Completada]
  • Redactar 1000 mensajes [✔ Completada]
#2
podrias dejarme el link de tu foro y que codigo usas para el spoiler......



de casualidad revisaste q el codigo fuente este bien escrito xq revise y no tiene el javascript con la funcion activa si usas plugin menciona cual es si usas MyCode deja el codigo que usaste o tienes actualmente en el manejo de tu foro
WWW
#3
(30-05-2013, 07:44 PM)Dark_Soul escribió: podrias dejarme el link de tu foro y que codigo usas para el spoiler...

El foro es http://foro.nfswo.com.ar/ y el código... si gustás te podría dar los privilegios de técnico nuevamente Sonrisa
Metas¡Completadas!
  • Ascender a moderador [✔ Completada]
  • Ganar 50 puntos de reputación (ver) [✔ Completada]
  • Ganar 100 puntos de reputación (ver) [✔ Completada]
  • Redactar 1000 mensajes [✔ Completada]
#4
lee el mensaje anterior y espero tu respuesta...
WWW
#5
Probé el código BB en el panel de administración y funciona, por lo que creo que es algo de las plantillas. El código que estoy probando actualmente es este...

Expresión regular
Código:
\[spoiler\](.*?)\[/spoiler\]

Código HTML
Código:
<div>
<div class="pre-spoiler">
<span style="float: left; padding-top: 2px;">Contenido oculto</span> <input value="Mostrar" style="width: 80px; font-size: 12px; margin: 0px; padding: 0px;" onclick="if (this.parentNode.parentNode.getElementsByTagName('div')[1].getElementsByTagName('div')[0].style.display != '') { this.parentNode.parentNode.getElementsByTagName('div')[1].getElementsByTagName('div')[0].style.display = '';this.innerText = ''; this.value = 'Esconder'; } else { this.parentNode.parentNode.getElementsByTagName('div')[1].getElementsByTagName('div')[0].style.display = 'none'; this.value = 'Mostrar';}" type="button">
</div>
<div>
<div class="spoiler" style="display: none;">$1<br />

</div>
</div>
</div>

Adicional en global.css
Código:
.pre-spoiler {
border: 1px solid #005F96;
margin: 0 15px 5px 15px;
background: #DEEAEF;
padding: 3px 5px 3px 5px;
font-weight: bold;
text-align: right;
color: #5A6373;
}

.spoiler {
background: #DEEAEF;
margin: 0 15px 15px 15px;
padding: 5px;
border: 1px solid #005F96;
}
Metas¡Completadas!
  • Ascender a moderador [✔ Completada]
  • Ganar 50 puntos de reputación (ver) [✔ Completada]
  • Ganar 100 puntos de reputación (ver) [✔ Completada]
  • Redactar 1000 mensajes [✔ Completada]
#6
Yo te recomiendo instalar el plugin de abdon que lo puedes encontrar en soportemybb

Ese plugin nunca falla, e igual puedes personalizar el CSS a tu antojo
WWW
#7
el código funciona perfectamente revisa que lo tengas igual en tu pagina al parecer hay un código que interfiere con la funcion
WWW
#8
(30-05-2013, 08:06 PM)Juliens escribió: Yo te recomiendo instalar el plugin de abdon que lo puedes encontrar en soportemybb

Ese plugin nunca falla, e igual puedes personalizar el CSS a tu antojo

Justamente es el primero que usé y falló...
Metas¡Completadas!
  • Ascender a moderador [✔ Completada]
  • Ganar 50 puntos de reputación (ver) [✔ Completada]
  • Ganar 100 puntos de reputación (ver) [✔ Completada]
  • Redactar 1000 mensajes [✔ Completada]
#9
Un enlace donde estes utilizando la función del spoiler ??

te respondo a brevedad xD.
WWW
#10
Dark Neo, acá lo estaba usando: http://foro.nfswo.com.ar/Tema-Corrupci%C...39#pid3839

Pero ya lo desactivé. Voy a volver a instalar el de SoporteMyBB y te aviso.

Acabo de activar el plugin que me recomendaron, pero sigue fallando el botón Indeciso
Metas¡Completadas!
  • Ascender a moderador [✔ Completada]
  • Ganar 50 puntos de reputación (ver) [✔ Completada]
  • Ganar 100 puntos de reputación (ver) [✔ Completada]
  • Redactar 1000 mensajes [✔ Completada]


Posibles temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Problema con traducciones de plugins redwonderland 1 359 28-09-2015, 06:21 AM
Último mensaje: garcon
  Problema con el sistema de agradecimiento 2.4.4 DoMiNiCki 5 497 12-12-2014, 06:32 PM
Último mensaje: Vicen
  Solucionado: Problema con cache celticslment 1 479 30-07-2014, 10:40 AM
Último mensaje: AbaddonOrmuz
  Solucionado: Problema en inicio de sesión Tangoth 9 807 12-07-2014, 10:33 PM
Último mensaje: Vicen
  ¿Problema en pantallas pequeñas? ariel 34 1,821 22-05-2014, 11:17 AM
Último mensaje: Dark_Soul
  Solucionado: Problema con Myalerts angelismo 10 877 15-02-2014, 07:47 PM
Último mensaje: angelismo
  Problema con el spoiler Foros Elite 4 604 29-10-2013, 10:31 PM
Último mensaje: Dark Neo
  Problema con SEO Finer 2 566 28-08-2013, 12:56 AM
Último mensaje: blackandroid
  Solucionado: Problema con sistema de migración ariel 19 1,122 15-06-2013, 03:41 PM
Último mensaje: ariel



Usuarios navegando en este tema: 1 invitado(s)