Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLUCIONADO] Que significa este error...
#1
Hola, tengo instalado en mi web el componente JEvents. y me muestra el siguiente error:

Warning: Invalid argument supplied for foreach() in /var/www/vhost/carnavaleando.com/home/html/libraries/joomla/registry/registry.php on line 423

Lo podeis ver en el siguiente enlace: http://carnavaleando.com/index.php/compo...=01&day=30

¿Alguien sabe porque me sale ese error?

Saludos de Aguma.
#2
Pues probablemente lo esté provocando el componente q has instalado. Puede venir provocado por la versión de PHP q estás usando y q no sea compatible con el componente. O pudiera ser una incorrecta coniguración del componente o un mal funcionamiento de éste.

Si el componente te funciona bien, podemos hacer que dicho error no aparezca.
[Imagen: firmabp.jpg][Imagen: mineenlineaentregadispo.jpg]
WWW
#3
El componente funciona bien, ¿Como lo podria quitar el error?.

Saludos.
#4
Accede al archivo "/var/www/vhost/carnavaleando.com/home/html/libraries/joomla/registry/registry.php" y busca la línea 423 donde verás un foreach en una cosa así:
foreach ($esto as $estootro) {
....
}

Pues śolo coloca una arroba delante del foreach:
@foreach ($esto as $estootro) {

Eso es tódo, la línea se ejecutará pero no mostrará error alguno.

Es sólo un poco de "juego sucio"
[Imagen: firmabp.jpg][Imagen: mineenlineaentregadispo.jpg]
WWW
#5
Jaja Mine... Que bueno... Ahora me apunto ese truquillo xD
WWW
#6
Hola Minenage, si añado la @ que me comentas en la fila 423 me muestra el siguiente error y deja de funcionar la web:

Parse error: syntax error, unexpected T_FOREACH in /var/www/vhost/carnavaleando.com/home/html/libraries/joomla/registry/registry.php on line 423
#7
Aguma escribió:Hola Minenage, si añado la @ que me comentas en la fila 423 me muestra el siguiente error y deja de funcionar la web:

Parse error: syntax error, unexpected T_FOREACH in /var/www/vhost/carnavaleando.com/home/html/libraries/joomla/registry/registry.php on line 423
El @ debe ir delante de la instrucción "foreach". A unas malas... postea desde la línea 400 a la 500 y vemos el código ya q estoy hablando sin conocer el código real.
[Imagen: firmabp.jpg][Imagen: mineenlineaentregadispo.jpg]
WWW
#8
Ya he dado con el error Minenage, era que tenia instalado el componente Yvcoment y el componente JComments, entonces he eliminado el Yvcoment porque al crear un nuevo evento me salio un error que mencionaba el Yvcoment, no sabia que lo tenia instalado jejeje, asi que solucionado.

Muchas gracias Sonrisa .
#9
Aguma escribió:Ya he dado con el error Minenage, era que tenia instalado el componente Yvcoment y el componente JComments, entonces he eliminado el Yvcoment porque al crear un nuevo evento me salio un error que mencionaba el Yvcoment, no sabia que lo tenia instalado jejeje, asi que solucionado.

Muchas gracias Sonrisa .
Significa eso q era una incompatibilidad de componentes?
[Imagen: firmabp.jpg][Imagen: mineenlineaentregadispo.jpg]
WWW
#10
Seguramente es eso, o que al ver un componente que hay una acción que debería de haber realizado el, y no ha sido realizada por el, pues saca la alarma, pero no se xD

Marco como solucionado Guiño
WWW


Posibles temas similares...
Tema Autor Respuestas Vistas Último mensaje
  [SOLUCIONADO] - Mi Joomla no se actualiza Aguma 5 1,332 10-09-2010, 04:11 AM
Último mensaje: Taquion
  Solucionado: [solucionado] Configurar el RSS de mi web Joomla Aguma 11 3,950 20-08-2010, 06:45 PM
Último mensaje: Minenage
  [SOLUCIONADO] No puedo instalar ningun componente, modulo... Aguma 7 1,273 29-06-2010, 07:06 PM
Último mensaje: Arrakis
  [SOLUCIONADO] Formulario en mi web (CK Forms) Aguma 31 8,666 16-05-2010, 09:29 PM
Último mensaje: Minenage
  [SOLUCIONADO] Componente Predicción del Tiempo Aguma 9 1,009 28-03-2010, 12:17 PM
Último mensaje: papi
  [solucionado] Peso de una web Joomla Aguma 43 3,921 26-03-2010, 01:51 PM
Último mensaje: Aguma
  [SOLUCIONADO] Crear un sitemap perfecto para Joomla. Aguma 7 1,145 26-03-2010, 12:14 PM
Último mensaje: papi
  [SOLUCIONADO] Joomla tarda mucho en cargar Aguma 8 5,268 22-03-2010, 03:39 PM
Último mensaje: Minenage
  [SOLUCIONADO] Solucion para mensajes en !JoomlaComment 4.0 Aguma 25 3,701 19-12-2009, 03:49 PM
Último mensaje: papi
  [SOLUCIONADO] Nieve en Joomla. Aguma 12 3,391 18-12-2009, 12:17 AM
Último mensaje: Taquion



Usuarios navegando en este tema: 1 invitado(s)