Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Signos raros en acentos y letras
#1
Hola, bueno quiero saber como solucionar este problema, lo que pasa es que cada vez que pongo un acento o una Ñ, sale este icono �, que debo hacer para arreglarlo?

También quisiera saber que debo editar para eliminar esto:

[Imagen: 8202888b062bb2bcb3ef2ed7ed45162eo.png]

Esa sección marcada en rojo que dice "Peliculas por Orden Alfabetico" no se que debo editar para arreglar eso. Yo solo quiero que sea vea lo de aviso legal.

http://www.cinelan.skn1.com/page/aviso-legal.html

SCRIPT: MOVIESCRIPT
Espero una respuesta, saludos!
#2
Con lo primero checa la codificación que usa, la estándar es utf-8

Con lo segundo si carga el aviso legal, despees de unos segundos
Cualquier duda, pregunta, comentario... Aquí estoy Guiño
#3
Podrias proporcionar mas información como por ejemplo, que cms usas.
WWW
#4
Te edito el post para añadir tu CMS para que puedan ayudarte.
Cualquier duda, pregunta, comentario... Aquí estoy Guiño
#5
como te dijeron ahi arriba debes revisar que el codigo de tus archivos este en utf-8 (preferiblemente sin Bom)
WWW
#6
Para asegurarse, un guardar como: utf-8 sin bom, los archivos , cual..no sé...no se que script usas
slds
#7
Checa lo siguiente:

- Que tus tablas (MySQL) esten codificadas en utf8_unicode_ci
- Que justo después de la conexión a la base de datos se especifique la codificación en UTF-8.

No sé que driver utilices, pero en PDO (MySQL) se puede especificar en las opciones del driver, ejemplo:

Código PHP:
$dbh = new PDO('dsn''usuaroi''contraseña', array(
    
PDO::ATTR_ERRMODE            => PDO::ERRMODE_EXCEPTION,
    
PDO::MYSQL_ATTR_INIT_COMMAND => 'SET NAMES utf8'
)); 

En MySQLi existe mysqli:Confundidoet_charset

- También añade el metatag en tu header, preferentemente justo después de abrir <head>

Código:
<meta charset="utf-8" />
WWW
#8
Yo opino que tb es problema de UTF8 definelo en header del HTML y las tablas de Mysql cambialas a UTF8
#9
Como te indica mi compañero es la solución también se puede meter por php <?php
header('Content-Type: text/html; charset=UTF-8'); ?>
WWW
#10
Como te dijeron los amigos arriba se debe a que no estás utilizando UTF-8 en el código. Intenta seguir lo que AbaddonOrmuz escribió. También puedes cambiar en el código las letras y signos de pregunta/admiración de la siguiente manera:

á > &aacute;
é > &eacute;
í > &iacute;
ó > &oacute;
ú > &uacute;
¿ > &iquest;
¡ > &iexcl;

Te dejo esto por si utilizas otros caracteres y te sale el �: http://ascii.cl/es/codigos-html.htm
Metas¡Completadas!
  • Ascender a moderador [✔ Completada]
  • Ganar 50 puntos de reputación (ver) [✔ Completada]
  • Ganar 100 puntos de reputación (ver) [✔ Completada]
  • Redactar 1000 mensajes [✔ Completada]


Posibles temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Acentos y otros símbolos (HTML) Taquion 1 1,131 01-08-2014, 03:42 AM
Último mensaje: Kevin9908
  Ayuda con los acentos y caracteres utf-8 DarkMaster 6 1,124 18-05-2012, 09:38 PM
Último mensaje: papi
  Mis Letras Aparecen Muy Juntas tutee 1 909 28-12-2011, 03:33 PM
Último mensaje: papi
  Solucionar el problema de los acentos y eñes xester2011 2 1,126 06-11-2011, 05:39 PM
Último mensaje: Juliens



Usuarios navegando en este tema: 1 invitado(s)