Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Solucionado Problema con bloque Foro
#1
Buenos días tengo varias paginas y en todas me sucede lo mismo, pensaba que era problema del "theme" pero al parecer es del core. Bueno me sucede lo siguiente. Cuando pongo el bloque de ACTIVE FORUM TOPICS, en la region sidebar por ejemplo a los usuarios les aparece una pestaña o link para "configure block"
Por supuesto que en la opcion del bloque Users > Customizable per user >Not customizable esta activada.

No se que hacer y la verdad es un bloque que me interesa mucho.

Muchas gracias como siempre Guiño

pLay Guiño
#2
prueba lo siguiente: (espero que sea drupal)

Abre: modules/forum/forum.module

Encuentra:
Código:
$block['content'] = drupal_render_cache_by_query($query, 'forum_block_view');

Sustitúyelo por:
Código:
$block['content'] = drupal_render_cache_by_query($query, 'forum_block_view', CACHE_TEMPORARY, DRUPAL_CACHE_PER_ROLE);

espero te sirva!
[Imagen: Bann.png]
WWW
#3
Mira los permisos de los usuarios y mira a ver si tienen activado algún permiso no deseado.

PD: Parece que Taq se me ha adelantado, pero bueno, ahí te dejo lo mío también Guiño
[Imagen: firmatwitter.png][Imagen: firmataq.png]
WWW
#4
Muchas gracias, siempre contestais rapidisimo Guiño Ahora al hacer el cambio, el bloque no me muestra el contenido. Triste Sabeis a que se debe ?
#5
Buenas Tardes aquí encontré la solución:
http://drupal.org/files/issues/914382-forum-d7.patch
Muchas gracias.
#6
Perdona por no contestar pero se me debió de saltar el post. Me alegro de que encontraras el fallo.

Muchos de los errores que ocurren en una web siempre hay alguna solución buscándola en Google ya que a todos nos ha podido pasar Guiño
[Imagen: firmatwitter.png][Imagen: firmataq.png]
WWW
#7
gsplay escribió:Buenas Tardes aquí encontré la solución:
http://drupal.org/files/issues/914382-forum-d7.patch

Muchas gracias.


Gracias a ti por poner la solucion a ese problema ya que a muchos puede que le sirva ese tip Guiño
WWW
#8
exacto ese es justo el aprche que te puse, buenoq ue lo hayas encontrado
[Imagen: Bann.png]
WWW
#9
Edito: Marco como solucionado y cierro el tema


Posibles temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Solucionado: [SOLUCIONADO] Problema al Instalar Drupal El_mago 10 1.902 06-01-2013, 07:48 PM
Último mensaje: MrLoco
  Solucionado: drupal 7 Foro cus 7 742 22-03-2012, 05:53 PM
Último mensaje: Juliens
  Pequeño problema con CKEditor en Drupal Arrakis 14 2.862 07-04-2010, 01:51 PM
Último mensaje: Arrakis



Usuarios navegando en este tema: 1 invitado(s)