Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Solucionado problema con insert into sql
#1
Os comento, antes de la mudanza esta sentencia me iba bien, ahora no me va.

Y no consigo ver el fallo.

$linea = "INSERT INTO ninos (nombre,dni,domicilio,telefono1,telefono2,telefono3,colegio,tutor,equipo_procedencia,lateralidad,clubs,categoria,tallaje,situacion,dia_nacimiento,mes_nacimiento,anio_nacimiento,dia_alta,mes_alta,anio_alta,activo,ruta_imagen)
VALUES
('".$_POST["nombre_nino"]."','".$_POST["dni"]."','".$_POST["domicilio"]."','".$_POST["telefono1"]."','".$_POST["telefono2"]."','".$_POST["telefono3"]."','".$_POST["colegio"]."','".$_POST["tutor"]."','".$_POST["equipo_procedencia"]."','".$_POST["lateralidad"]."','".$_POST["clubs"]."','".$_POST["categoria"]."','".$_POST["talla"]."','".$_POST["contratacion"]."','".$_POST["dia_nacimiento"]."','".$_POST["mes_nacimiento"]."','".$_POST["anio_nacimiento"]."','".$_POST["dia_club"]."','".$_POST["mes_club"]."','".$_POST["anio_club"]."','si','".$_FILES['uploadedfile']['name']."')";

mysql_query($linea);
#2
Hola,

Antes de nada seria bueno que pasases a mysqli o pdo  ya que cada vez mysql esta más obsoleta no obstante dime donde estás ejecutando esa linea así poder revisar y ayudarte.

Si quieres envíame la información por MP y le doy un vistazo debido a que varios códigos se han tenido que adaptar tras las actualizaciones del servidor.

Saludos.
WWW
#3
esta dentro de un modulo blank, se llama  nuevo niño, de php de la web de escuelabahia.skn1.com, lo mas curioso es que las sentencia de buscar o de ver si me la hace correctamente.

El numero de la linea es 418.

He visto por el foro del soporte, que a otra persona le pasaba algo parecido, ¿ puede ser por que no tenga ningun valor predeterminado en los campos?
#4
(25-01-2018, 01:29 PM)efbsfcd escribió: esta dentro de un modulo blank, se llama  nuevo niño, de php de la web de escuelabahia.skn1.com, lo mas curioso es que las sentencia de buscar o de ver si me la hace correctamente.

El numero de la linea es 418.

He visto por el foro del soporte, que a otra persona le pasaba algo parecido, ¿ puede ser por que no tenga ningun valor predeterminado en los campos?


Si también puede ser, si no ves error en la linea será de la db.

Te envió MP.
WWW
#5
Ya esta solucionado, cual era el problema, en mi base de datos tengo algunas tablas cuya primery key es serial y se auto incrementa, es decir no hace falta que la meta, segun comprobaciones que he realizado, tienes que meter abosulamente todos los campos, asi puesta la incrementacion ahora la hago manualmente.
#6
Si es común el uso de incrementar no deberia ser el problema,

Marco y Cierro.
WWW


Posibles temas similares...
Tema Autor Respuestas Vistas Último mensaje
  [Duda] Problema DHTML PabloA3 0 58 06-09-2018, 04:26 PM
Último mensaje: PabloA3
Bug Problema conectando con MySql remoto yuma2009 2 293 01-02-2018, 11:52 AM
Último mensaje: easy english
  Problema conexion remota mysql efbsfcd 2 343 07-07-2017, 07:19 AM
Último mensaje: efbsfcd
  Problema con la web dormio 5 441 17-12-2014, 03:26 PM
Último mensaje: jebcalix
  Problema con transición css celticslment 3 459 15-11-2014, 11:16 AM
Último mensaje: kakashi-sensei
  Problema con imagenes othgeg 14 1,138 01-09-2014, 12:43 AM
Último mensaje: romeho
  THT - Problema con licencia Gonzalo 1 516 08-12-2013, 04:59 AM
Último mensaje: DarkMaster
  Problema grave en mi web Gonzalo 20 1,481 26-11-2013, 06:39 PM
Último mensaje: papi
  Problema con mensajes basura en mi foro. slayer 9 958 14-09-2013, 02:42 AM
Último mensaje: esteban
  Problema con php script - AYUDA!!! alemagno 10 1,300 23-08-2013, 04:53 PM
Último mensaje: AbaddonOrmuz



Usuarios navegando en este tema: 1 invitado(s)