Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Solucionar el problema de los acentos y eñes
#1
1- Para solucionar el problema de los acentos y eñes
Al crear la base de datos MySQL, asegurese que el cotejamiento de las tablas en utf_unicode_ci

[Imagen: utf_01.jpg]


2- Al crear las tablas MySQL, asegurese que el cotejamiento este fijado en utf_unicode_ci

[Imagen: utf_02.jpg]

3- Al crear los campos de las tablas, verifique que los campos referentes a cadenas de texto (text, varchar, etc) este en utf8_spanish_ci

[Imagen: utf_03.jpg]

4- Coloque en el <head> de todos los archivos HTML:
<meta http-equiv="Content-type" content="text/html; charset=utf-8" />

5- Y en los puramente PHP (que muestran XML, llamadas de AJAX, APIs) agregue el código:
header("Content-Type: text/html;charset=utf-8");

6- Al crear la conexión de PHP con MySQL, envíe esta consulta despues de hacer la conexión
mysql_query("SET NAMES 'utf8'");

7- Si es necesario, cree un archivo de nombre .htaccess en la raiz de su sitio con el contenido:
AddDefaultCharset UTF-8
Si el archivo ya fue creado por su sistema de administración de contenidos (Joomla, Wordpress, Drupal), agregue la linea a las ya existentes.

R. Robles
#2
Genial pero la proxima usa BBCODES Guiño .
Cualquier duda, pregunta, comentario... Aquí estoy Guiño
#3
Buen tuto, bien explicado.

Por ahí leí que ese formato de MySql es el mejor; pero también funciona el utf_bin; yo lo utilizaba en el foro que tenía y no me daba problemas
WWW


Posibles temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Problema conexion remota mysql efbsfcd 2 41 07-07-2017, 07:19 AM
Último mensaje: efbsfcd
  Problema con la web dormio 5 225 17-12-2014, 03:26 PM
Último mensaje: jebcalix
  Problema con transición css celticslment 3 293 15-11-2014, 11:16 AM
Último mensaje: kakashi-sensei
  Problema con imagenes othgeg 14 714 01-09-2014, 12:43 AM
Último mensaje: romeho
  Signos raros en acentos y letras Cine-lan 11 708 06-08-2014, 03:29 AM
Último mensaje: craick
  Acentos y otros símbolos (HTML) Taquion 1 1,123 01-08-2014, 03:42 AM
Último mensaje: Kevin9908
  THT - Problema con licencia Gonzalo 1 368 08-12-2013, 04:59 AM
Último mensaje: DarkMaster
  Problema grave en mi web Gonzalo 20 1,067 26-11-2013, 06:39 PM
Último mensaje: papi
  Problema con mensajes basura en mi foro. slayer 9 651 14-09-2013, 02:42 AM
Último mensaje: esteban
  Problema con php script - AYUDA!!! alemagno 10 1,019 23-08-2013, 04:53 PM
Último mensaje: AbaddonOrmuz



Usuarios navegando en este tema: 1 invitado(s)